Casts (174)

Cast
int8::int2
int8::int4
int8::float4
int8::float8
int8::numeric
int2::int8
int2::int4
int2::float4
int2::float8
int2::numeric
int4::int8
int4::int2
int4::float4
int4::float8
int4::numeric
float4::int8
float4::int2
float4::int4
float4::float8
float4::numeric
float8::int8
float8::int2
float8::int4
float8::float4
float8::numeric
numeric::int8
numeric::int2
numeric::int4
numeric::float4
numeric::float8
int8::oid
int2::oid
int4::oid
oid::int8
oid::int4
oid::regproc
regproc::oid
int8::regproc
int2::regproc
int4::regproc
regproc::int8
regproc::int4
regproc::regprocedure
regprocedure::regproc
oid::regprocedure
regprocedure::oid
int8::regprocedure
int2::regprocedure
int4::regprocedure
regprocedure::int8
regprocedure::int4
oid::regoper
regoper::oid
int8::regoper
int2::regoper
int4::regoper
regoper::int8
regoper::int4
regoper::regoperator
regoperator::regoper
oid::regoperator
regoperator::oid
int8::regoperator
int2::regoperator
int4::regoperator
regoperator::int8
regoperator::int4
oid::regclass
regclass::oid
int8::regclass
int2::regclass
int4::regclass
regclass::int8
regclass::int4
oid::regtype
regtype::oid
int8::regtype
int2::regtype
int4::regtype
regtype::int8
regtype::int4
text::bpchar
text::varchar
bpchar::text
bpchar::varchar
varchar::text
varchar::bpchar
char::text
char::bpchar
name::text
name::bpchar
name::varchar
text::char
text::name
bpchar::name
varchar::name
abstime::date
abstime::time
abstime::timestamp
abstime::timestamptz
reltime::interval
date::timestamp
date::timestamptz
time::interval
time::timetz
timestamp::abstime
timestamp::date
timestamp::time
timestamp::timestamptz
timestamptz::abstime
timestamptz::date
timestamptz::time
timestamptz::timestamp
timestamptz::timetz
interval::reltime
interval::time
timetz::time
int4::abstime
abstime::int4
int4::reltime
reltime::int4
lseg::point
path::point
path::polygon
box::point
box::lseg
box::polygon
box::circle
polygon::point
polygon::path
polygon::box
polygon::circle
circle::point
circle::box
circle::polygon
cidr::inet
inet::cidr
bit::varbit
varbit::bit
int8::bit
int4::bit
bit::int8
bit::int4
int8::text
text::int8
int2::text
text::int2
int4::text
text::int4
oid::text
text::oid
text::cidr
float4::text
text::float4
float8::text
text::float8
macaddr::text
text::macaddr
inet::text
text::inet
date::text
text::date
time::text
text::time
timestamp::text
text::timestamp
timestamptz::text
text::timestamptz
interval::text
text::interval
timetz::text
text::timetz
numeric::text
text::numeric

pgAdmin II - PostgreSQL Tools

Copyright (C) 2001, 2003, The pgAdmin Development Team

This software is released under the pgAdmin Public Licence


int8::int2

Property | Value
Name | int8::int2
OID | 16420
Type source | int8
Type target | int2
Function | int2
Context |
System Cast? | Yes
Sql | -- Cast: "int8::int2" CREATE CAST (int8 AS int2) WITH FUNCTION int2(int8) AS ASSIGNMENT


int8::int4

Property | Value
Name | int8::int4
OID | 16421
Type source | int8
Type target | int4
Function | int4
Context |
System Cast? | Yes
Sql | -- Cast: "int8::int4" CREATE CAST (int8 AS int4) WITH FUNCTION int4(int8) AS ASSIGNMENT


int8::float4

Property | Value
Name | int8::float4
OID | 16422
Type source | int8
Type target | float4
Function | float4
Context |
System Cast? | Yes
Sql | -- Cast: "int8::float4" CREATE CAST (int8 AS float4) WITH FUNCTION float4(int8) AS IMPLICIT


int8::float8

Property | Value
Name | int8::float8
OID | 16423
Type source | int8
Type target | float8
Function | float8
Context |
System Cast? | Yes
Sql | -- Cast: "int8::float8" CREATE CAST (int8 AS float8) WITH FUNCTION float8(int8) AS IMPLICIT


int8::numeric

Property | Value
Name | int8::numeric
OID | 16424
Type source | int8
Type target | numeric
Function | numeric
Context |
System Cast? | Yes
Sql | -- Cast: "int8::numeric" CREATE CAST (int8 AS numeric) WITH FUNCTION numeric(int8) AS IMPLICIT


int2::int8

Property | Value
Name | int2::int8
OID | 16425
Type source | int2
Type target | int8
Function | int8
Context |
System Cast? | Yes
Sql | -- Cast: "int2::int8" CREATE CAST (int2 AS int8) WITH FUNCTION int8(int2) AS IMPLICIT


int2::int4

Property | Value
Name | int2::int4
OID | 16426
Type source | int2
Type target | int4
Function | int4
Context |
System Cast? | Yes
Sql | -- Cast: "int2::int4" CREATE CAST (int2 AS int4) WITH FUNCTION int4(int2) AS IMPLICIT


int2::float4

Property | Value
Name | int2::float4
OID | 16427
Type source | int2
Type target | float4
Function | float4
Context |
System Cast? | Yes
Sql | -- Cast: "int2::float4" CREATE CAST (int2 AS float4) WITH FUNCTION float4(int2) AS IMPLICIT


int2::float8

Property | Value
Name | int2::float8
OID | 16428
Type source | int2
Type target | float8
Function | float8
Context |
System Cast? | Yes
Sql | -- Cast: "int2::float8" CREATE CAST (int2 AS float8) WITH FUNCTION float8(int2) AS IMPLICIT


int2::numeric

Property | Value
Name | int2::numeric
OID | 16429
Type source | int2
Type target | numeric
Function | numeric
Context |
System Cast? | Yes
Sql | -- Cast: "int2::numeric" CREATE CAST (int2 AS numeric) WITH FUNCTION numeric(int2) AS IMPLICIT


int4::int8

Property | Value
Name | int4::int8
OID | 16430
Type source | int4
Type target | int8
Function | int8
Context |
System Cast? | Yes
Sql | -- Cast: "int4::int8" CREATE CAST (int4 AS int8) WITH FUNCTION int8(int4) AS IMPLICIT


int4::int2

Property | Value
Name | int4::int2
OID | 16431
Type source | int4
Type target | int2
Function | int2
Context |
System Cast? | Yes
Sql | -- Cast: "int4::int2" CREATE CAST (int4 AS int2) WITH FUNCTION int2(int4) AS ASSIGNMENT


int4::float4

Property | Value
Name | int4::float4
OID | 16432
Type source | int4
Type target | float4
Function | float4
Context |
System Cast? | Yes
Sql | -- Cast: "int4::float4" CREATE CAST (int4 AS float4) WITH FUNCTION float4(int4) AS IMPLICIT


int4::float8

Property | Value
Name | int4::float8
OID | 16433
Type source | int4
Type target | float8
Function | float8
Context |
System Cast? | Yes
Sql | -- Cast: "int4::float8" CREATE CAST (int4 AS float8) WITH FUNCTION float8(int4) AS IMPLICIT


int4::numeric

Property | Value
Name | int4::numeric
OID | 16434
Type source | int4
Type target | numeric
Function | numeric
Context |
System Cast? | Yes
Sql | -- Cast: "int4::numeric" CREATE CAST (int4 AS numeric) WITH FUNCTION numeric(int4) AS IMPLICIT


float4::int8

Property | Value
Name | float4::int8
OID | 16435
Type source | float4
Type target | int8
Function | int8
Context |
System Cast? | Yes
Sql | -- Cast: "float4::int8" CREATE CAST (float4 AS int8) WITH FUNCTION int8(float4) AS ASSIGNMENT


float4::int2

Property | Value
Name | float4::int2
OID | 16436
Type source | float4
Type target | int2
Function | int2
Context |
System Cast? | Yes
Sql | -- Cast: "float4::int2" CREATE CAST (float4 AS int2) WITH FUNCTION int2(float4) AS ASSIGNMENT


float4::int4

Property | Value
Name | float4::int4
OID | 16437
Type source | float4
Type target | int4
Function | int4
Context |
System Cast? | Yes
Sql | -- Cast: "float4::int4" CREATE CAST (float4 AS int4) WITH FUNCTION int4(float4) AS ASSIGNMENT


float4::float8

Property | Value
Name | float4::float8
OID | 16438
Type source | float4
Type target | float8
Function | float8
Context |
System Cast? | Yes
Sql | -- Cast: "float4::float8" CREATE CAST (float4 AS float8) WITH FUNCTION float8(float4) AS IMPLICIT


float4::numeric

Property | Value
Name | float4::numeric
OID | 16439
Type source | float4
Type target | numeric
Function | numeric
Context |
System Cast? | Yes
Sql | -- Cast: "float4::numeric" CREATE CAST (float4 AS numeric) WITH FUNCTION numeric(float4) AS ASSIGNMENT


float8::int8

Property | Value
Name | float8::int8
OID | 16440
Type source | float8
Type target | int8
Function | int8
Context |
System Cast? | Yes
Sql | -- Cast: "float8::int8" CREATE CAST (float8 AS int8) WITH FUNCTION int8(float8) AS ASSIGNMENT


float8::int2

Property | Value
Name | float8::int2
OID | 16441
Type source | float8
Type target | int2
Function | int2
Context |
System Cast? | Yes
Sql | -- Cast: "float8::int2" CREATE CAST (float8 AS int2) WITH FUNCTION int2(float8) AS ASSIGNMENT


float8::int4

Property | Value
Name | float8::int4
OID | 16442
Type source | float8
Type target | int4
Function | int4
Context |
System Cast? | Yes
Sql | -- Cast: "float8::int4" CREATE CAST (float8 AS int4) WITH FUNCTION int4(float8) AS ASSIGNMENT


float8::float4

Property | Value
Name | float8::float4
OID | 16443
Type source | float8
Type target | float4
Function | float4
Context |
System Cast? | Yes
Sql | -- Cast: "float8::float4" CREATE CAST (float8 AS float4) WITH FUNCTION float4(float8) AS ASSIGNMENT


float8::numeric

Property | Value
Name | float8::numeric
OID | 16444
Type source | float8
Type target | numeric
Function | numeric
Context |
System Cast? | Yes
Sql | -- Cast: "float8::numeric" CREATE CAST (float8 AS numeric) WITH FUNCTION numeric(float8) AS ASSIGNMENT


numeric::int8

Property | Value
Name | numeric::int8
OID | 16445
Type source | numeric
Type target | int8
Function | int8
Context |
System Cast? | Yes
Sql | -- Cast: "numeric::int8" CREATE CAST (numeric AS int8) WITH FUNCTION int8(numeric) AS ASSIGNMENT


numeric::int2

Property | Value
Name | numeric::int2
OID | 16446
Type source | numeric
Type target | int2
Function | int2
Context |
System Cast? | Yes
Sql | -- Cast: "numeric::int2" CREATE CAST (numeric AS int2) WITH FUNCTION int2(numeric) AS ASSIGNMENT


numeric::int4

Property | Value
Name | numeric::int4
OID | 16447
Type source | numeric
Type target | int4
Function | int4
Context |
System Cast? | Yes
Sql | -- Cast: "numeric::int4" CREATE CAST (numeric AS int4) WITH FUNCTION int4(numeric) AS ASSIGNMENT


numeric::float4

Property | Value
Name | numeric::float4
OID | 16448
Type source | numeric
Type target | float4
Function | float4
Context |
System Cast? | Yes
Sql | -- Cast: "numeric::float4" CREATE CAST (numeric AS float4) WITH FUNCTION float4(numeric) AS IMPLICIT


numeric::float8

Property | Value
Name | numeric::float8
OID | 16449
Type source | numeric
Type target | float8
Function | float8
Context |
System Cast? | Yes
Sql | -- Cast: "numeric::float8" CREATE CAST (numeric AS float8) WITH FUNCTION float8(numeric) AS IMPLICIT


int8::oid

Property | Value
Name | int8::oid
OID | 16450
Type source | int8
Type target | oid
Function | oid
Context |
System Cast? | Yes
Sql | -- Cast: "int8::oid" CREATE CAST (int8 AS oid) WITH FUNCTION oid(int8) AS IMPLICIT


int2::oid

Property | Value
Name | int2::oid
OID | 16451
Type source | int2
Type target | oid
Function | int4
Context |
System Cast? | Yes
Sql | -- Cast: "int2::oid" CREATE CAST (int2 AS oid) WITH FUNCTION int4(int2) AS IMPLICIT


int4::oid

Property | Value
Name | int4::oid
OID | 16452
Type source | int4
Type target | oid
Function |
Context |
System Cast? | Yes
Sql | -- Cast: "int4::oid" CREATE CAST (int4 AS oid) WITHOUT FUNCTION AS IMPLICIT


oid::int8

Property | Value
Name | oid::int8
OID | 16453
Type source | oid
Type target | int8
Function | int8
Context |
System Cast? | Yes
Sql | -- Cast: "oid::int8" CREATE CAST (oid AS int8) WITH FUNCTION int8(oid) AS ASSIGNMENT


oid::int4

Property | Value
Name | oid::int4
OID | 16454
Type source | oid
Type target | int4
Function |
Context |
System Cast? | Yes
Sql | -- Cast: "oid::int4" CREATE CAST (oid AS int4) WITHOUT FUNCTION AS ASSIGNMENT


oid::regproc

Property | Value
Name | oid::regproc
OID | 16455
Type source | oid
Type target | regproc
Function |
Context |
System Cast? | Yes
Sql | -- Cast: "oid::regproc" CREATE CAST (oid AS regproc) WITHOUT FUNCTION AS IMPLICIT


regproc::oid

Property | Value
Name | regproc::oid
OID | 16456
Type source | regproc
Type target | oid
Function |
Context |
System Cast? | Yes
Sql | -- Cast: "regproc::oid" CREATE CAST (regproc AS oid) WITHOUT FUNCTION AS IMPLICIT


int8::regproc

Property | Value
Name | int8::regproc
OID | 16457
Type source | int8
Type target | regproc
Function | oid
Context |
System Cast? | Yes
Sql | -- Cast: "int8::regproc" CREATE CAST (int8 AS regproc) WITH FUNCTION oid(int8) AS IMPLICIT


int2::regproc

Property | Value
Name | int2::regproc
OID | 16458
Type source | int2
Type target | regproc
Function | int4
Context |
System Cast? | Yes
Sql | -- Cast: "int2::regproc" CREATE CAST (int2 AS regproc) WITH FUNCTION int4(int2) AS IMPLICIT


int4::regproc

Property | Value
Name | int4::regproc
OID | 16459
Type source | int4
Type target | regproc
Function |
Context |
System Cast? | Yes
Sql | -- Cast: "int4::regproc" CREATE CAST (int4 AS regproc) WITHOUT FUNCTION AS IMPLICIT


regproc::int8

Property | Value
Name | regproc::int8
OID | 16460
Type source | regproc
Type target | int8
Function | int8
Context |
System Cast? | Yes
Sql | -- Cast: "regproc::int8" CREATE CAST (regproc AS int8) WITH FUNCTION int8(regproc) AS ASSIGNMENT


regproc::int4

Property | Value
Name | regproc::int4
OID | 16461
Type source | regproc
Type target | int4
Function |
Context |
System Cast? | Yes
Sql | -- Cast: "regproc::int4" CREATE CAST (regproc AS int4) WITHOUT FUNCTION AS ASSIGNMENT


regproc::regprocedure

Property | Value
Name | regproc::regprocedure
OID | 16462
Type source | regproc
Type target | regprocedure
Function |
Context |
System Cast? | Yes
Sql | -- Cast: "regproc::regprocedure" CREATE CAST (regproc AS regprocedure) WITHOUT FUNCTION AS IMPLICIT


regprocedure::regproc

Property | Value
Name | regprocedure::regproc
OID | 16463
Type source | regprocedure
Type target | regproc
Function |
Context |
System Cast? | Yes
Sql | -- Cast: "regprocedure::regproc" CREATE CAST (regprocedure AS regproc) WITHOUT FUNCTION AS IMPLICIT


oid::regprocedure

Property | Value
Name | oid::regprocedure
OID | 16464
Type source | oid
Type target | regprocedure
Function |
Context |
System Cast? | Yes
Sql | -- Cast: "oid::regprocedure" CREATE CAST (oid AS regprocedure) WITHOUT FUNCTION AS IMPLICIT


regprocedure::oid

Property | Value
Name | regprocedure::oid
OID | 16465
Type source | regprocedure
Type target | oid
Function |
Context |
System Cast? | Yes
Sql | -- Cast: "regprocedure::oid" CREATE CAST (regprocedure AS oid) WITHOUT FUNCTION AS IMPLICIT


int8::regprocedure

Property | Value
Name | int8::regprocedure
OID | 16466
Type source | int8
Type target | regprocedure
Function | oid
Context |
System Cast? | Yes
Sql | -- Cast: "int8::regprocedure" CREATE CAST (int8 AS regprocedure) WITH FUNCTION oid(int8) AS IMPLICIT


int2::regprocedure

Property | Value
Name | int2::regprocedure
OID | 16467
Type source | int2
Type target | regprocedure
Function | int4
Context |
System Cast? | Yes
Sql | -- Cast: "int2::regprocedure" CREATE CAST (int2 AS regprocedure) WITH FUNCTION int4(int2) AS IMPLICIT


int4::regprocedure

Property | Value
Name | int4::regprocedure
OID | 16468
Type source | int4
Type target | regprocedure
Function |
Context |
System Cast? | Yes
Sql | -- Cast: "int4::regprocedure" CREATE CAST (int4 AS regprocedure) WITHOUT FUNCTION AS IMPLICIT


regprocedure::int8

Property | Value
Name | regprocedure::int8
OID | 16469
Type source | regprocedure
Type target | int8
Function | int8
Context |
System Cast? | Yes
Sql | -- Cast: "regprocedure::int8" CREATE CAST (regprocedure AS int8) WITH FUNCTION int8(regprocedure) AS ASSIGNMENT


regprocedure::int4

Property | Value
Name | regprocedure::int4
OID | 16470
Type source | regprocedure
Type target | int4
Function |
Context |
System Cast? | Yes
Sql | -- Cast: "regprocedure::int4" CREATE CAST (regprocedure AS int4) WITHOUT FUNCTION AS ASSIGNMENT


oid::regoper

Property | Value
Name | oid::regoper
OID | 16471
Type source | oid
Type target | regoper
Function |
Context |
System Cast? | Yes
Sql | -- Cast: "oid::regoper" CREATE CAST (oid AS regoper) WITHOUT FUNCTION AS IMPLICIT


regoper::oid

Property | Value
Name | regoper::oid
OID | 16472
Type source | regoper
Type target | oid
Function |
Context |
System Cast? | Yes
Sql | -- Cast: "regoper::oid" CREATE CAST (regoper AS oid) WITHOUT FUNCTION AS IMPLICIT


int8::regoper

Property | Value
Name | int8::regoper
OID | 16473
Type source | int8
Type target | regoper
Function | oid
Context |
System Cast? | Yes
Sql | -- Cast: "int8::regoper" CREATE CAST (int8 AS regoper) WITH FUNCTION oid(int8) AS IMPLICIT


int2::regoper

Property | Value
Name | int2::regoper
OID | 16474
Type source | int2
Type target | regoper
Function | int4
Context |
System Cast? | Yes
Sql | -- Cast: "int2::regoper" CREATE CAST (int2 AS regoper) WITH FUNCTION int4(int2) AS IMPLICIT


int4::regoper

Property | Value
Name | int4::regoper
OID | 16475
Type source | int4
Type target | regoper
Function |
Context |
System Cast? | Yes
Sql | -- Cast: "int4::regoper" CREATE CAST (int4 AS regoper) WITHOUT FUNCTION AS IMPLICIT


regoper::int8

Property | Value
Name | regoper::int8
OID | 16476
Type source | regoper
Type target | int8
Function | int8
Context |
System Cast? | Yes
Sql | -- Cast: "regoper::int8" CREATE CAST (regoper AS int8) WITH FUNCTION int8(regoper) AS ASSIGNMENT


regoper::int4

Property | Value
Name | regoper::int4
OID | 16477
Type source | regoper
Type target | int4
Function |
Context |
System Cast? | Yes
Sql | -- Cast: "regoper::int4" CREATE CAST (regoper AS int4) WITHOUT FUNCTION AS ASSIGNMENT


regoper::regoperator

Property | Value
Name | regoper::regoperator
OID | 16478
Type source | regoper
Type target | regoperator
Function |
Context |
System Cast? | Yes
Sql | -- Cast: "regoper::regoperator" CREATE CAST (regoper AS regoperator) WITHOUT FUNCTION AS IMPLICIT


regoperator::regoper

Property | Value
Name | regoperator::regoper
OID | 16479
Type source | regoperator
Type target | regoper
Function |
Context |
System Cast? | Yes
Sql | -- Cast: "regoperator::regoper" CREATE CAST (regoperator AS regoper) WITHOUT FUNCTION AS IMPLICIT


oid::regoperator

Property | Value
Name | oid::regoperator
OID | 16480
Type source | oid
Type target | regoperator
Function |
Context |
System Cast? | Yes
Sql | -- Cast: "oid::regoperator" CREATE CAST (oid AS regoperator) WITHOUT FUNCTION AS IMPLICIT


regoperator::oid

Property | Value
Name | regoperator::oid
OID | 16481
Type source | regoperator
Type target | oid
Function |
Context |
System Cast? | Yes
Sql | -- Cast: "regoperator::oid" CREATE CAST (regoperator AS oid) WITHOUT FUNCTION AS IMPLICIT


int8::regoperator

Property | Value
Name | int8::regoperator
OID | 16482
Type source | int8
Type target | regoperator
Function | oid
Context |
System Cast? | Yes
Sql | -- Cast: "int8::regoperator" CREATE CAST (int8 AS regoperator) WITH FUNCTION oid(int8) AS IMPLICIT


int2::regoperator

Property | Value
Name | int2::regoperator
OID | 16483
Type source | int2
Type target | regoperator
Function | int4
Context |
System Cast? | Yes
Sql | -- Cast: "int2::regoperator" CREATE CAST (int2 AS regoperator) WITH FUNCTION int4(int2) AS IMPLICIT


int4::regoperator

Property | Value
Name | int4::regoperator
OID | 16484
Type source | int4
Type target | regoperator
Function |
Context |
System Cast? | Yes
Sql | -- Cast: "int4::regoperator" CREATE CAST (int4 AS regoperator) WITHOUT FUNCTION AS IMPLICIT


regoperator::int8

Property | Value
Name | regoperator::int8
OID | 16485
Type source | regoperator
Type target | int8
Function | int8
Context |
System Cast? | Yes
Sql | -- Cast: "regoperator::int8" CREATE CAST (regoperator AS int8) WITH FUNCTION int8(regoperator) AS ASSIGNMENT


regoperator::int4

Property | Value
Name | regoperator::int4
OID | 16486
Type source | regoperator
Type target | int4
Function |
Context |
System Cast? | Yes
Sql | -- Cast: "regoperator::int4" CREATE CAST (regoperator AS int4) WITHOUT FUNCTION AS ASSIGNMENT


oid::regclass

Property | Value
Name | oid::regclass
OID | 16487
Type source | oid
Type target | regclass
Function |
Context |
System Cast? | Yes
Sql | -- Cast: "oid::regclass" CREATE CAST (oid AS regclass) WITHOUT FUNCTION AS IMPLICIT


regclass::oid

Property | Value
Name | regclass::oid
OID | 16488
Type source | regclass
Type target | oid
Function |
Context |
System Cast? | Yes
Sql | -- Cast: "regclass::oid" CREATE CAST (regclass AS oid) WITHOUT FUNCTION AS IMPLICIT


int8::regclass

Property | Value
Name | int8::regclass
OID | 16489
Type source | int8
Type target | regclass
Function | oid
Context |
System Cast? | Yes
Sql | -- Cast: "int8::regclass" CREATE CAST (int8 AS regclass) WITH FUNCTION oid(int8) AS IMPLICIT


int2::regclass

Property | Value
Name | int2::regclass
OID | 16490
Type source | int2
Type target | regclass
Function | int4
Context |
System Cast? | Yes
Sql | -- Cast: "int2::regclass" CREATE CAST (int2 AS regclass) WITH FUNCTION int4(int2) AS IMPLICIT


int4::regclass

Property | Value
Name | int4::regclass
OID | 16491
Type source | int4
Type target | regclass
Function |
Context |
System Cast? | Yes
Sql | -- Cast: "int4::regclass" CREATE CAST (int4 AS regclass) WITHOUT FUNCTION AS IMPLICIT


regclass::int8

Property | Value
Name | regclass::int8
OID | 16492
Type source | regclass
Type target | int8
Function | int8
Context |
System Cast? | Yes
Sql | -- Cast: "regclass::int8" CREATE CAST (regclass AS int8) WITH FUNCTION int8(regclass) AS ASSIGNMENT


regclass::int4

Property | Value
Name | regclass::int4
OID | 16493
Type source | regclass
Type target | int4
Function |
Context |
System Cast? | Yes
Sql | -- Cast: "regclass::int4" CREATE CAST (regclass AS int4) WITHOUT FUNCTION AS ASSIGNMENT


oid::regtype

Property | Value
Name | oid::regtype
OID | 16494
Type source | oid
Type target | regtype
Function |
Context |
System Cast? | Yes
Sql | -- Cast: "oid::regtype" CREATE CAST (oid AS regtype) WITHOUT FUNCTION AS IMPLICIT


regtype::oid

Property | Value
Name | regtype::oid
OID | 16495
Type source | regtype
Type target | oid
Function |
Context |
System Cast? | Yes
Sql | -- Cast: "regtype::oid" CREATE CAST (regtype AS oid) WITHOUT FUNCTION AS IMPLICIT


int8::regtype

Property | Value
Name | int8::regtype
OID | 16496
Type source | int8
Type target | regtype
Function | oid
Context |
System Cast? | Yes
Sql | -- Cast: "int8::regtype" CREATE CAST (int8 AS regtype) WITH FUNCTION oid(int8) AS IMPLICIT


int2::regtype

Property | Value
Name | int2::regtype
OID | 16497
Type source | int2
Type target | regtype
Function | int4
Context |
System Cast? | Yes
Sql | -- Cast: "int2::regtype" CREATE CAST (int2 AS regtype) WITH FUNCTION int4(int2) AS IMPLICIT


int4::regtype

Property | Value
Name | int4::regtype
OID | 16498
Type source | int4
Type target | regtype
Function |
Context |
System Cast? | Yes
Sql | -- Cast: "int4::regtype" CREATE CAST (int4 AS regtype) WITHOUT FUNCTION AS IMPLICIT


regtype::int8

Property | Value
Name | regtype::int8
OID | 16499
Type source | regtype
Type target | int8
Function | int8
Context |
System Cast? | Yes
Sql | -- Cast: "regtype::int8" CREATE CAST (regtype AS int8) WITH FUNCTION int8(regtype) AS ASSIGNMENT


regtype::int4

Property | Value
Name | regtype::int4
OID | 16500
Type source | regtype
Type target | int4
Function |
Context |
System Cast? | Yes
Sql | -- Cast: "regtype::int4" CREATE CAST (regtype AS int4) WITHOUT FUNCTION AS ASSIGNMENT


text::bpchar

Property | Value
Name | text::bpchar
OID | 16501
Type source | text
Type target | bpchar
Function |
Context |
System Cast? | Yes
Sql | -- Cast: "text::bpchar" CREATE CAST (text AS bpchar) WITHOUT FUNCTION AS IMPLICIT


text::varchar

Property | Value
Name | text::varchar
OID | 16502
Type source | text
Type target | varchar
Function |
Context |
System Cast? | Yes
Sql | -- Cast: "text::varchar" CREATE CAST (text AS varchar) WITHOUT FUNCTION AS IMPLICIT


bpchar::text

Property | Value
Name | bpchar::text
OID | 16503
Type source | bpchar
Type target | text
Function |
Context |
System Cast? | Yes
Sql | -- Cast: "bpchar::text" CREATE CAST (bpchar AS text) WITHOUT FUNCTION AS IMPLICIT


bpchar::varchar

Property | Value
Name | bpchar::varchar
OID | 16504
Type source | bpchar
Type target | varchar
Function |
Context |
System Cast? | Yes
Sql | -- Cast: "bpchar::varchar" CREATE CAST (bpchar AS varchar) WITHOUT FUNCTION AS IMPLICIT


varchar::text

Property | Value
Name | varchar::text
OID | 16505
Type source | varchar
Type target | text
Function |
Context |
System Cast? | Yes
Sql | -- Cast: "varchar::text" CREATE CAST (varchar AS text) WITHOUT FUNCTION AS IMPLICIT


varchar::bpchar

Property | Value
Name | varchar::bpchar
OID | 16506
Type source | varchar
Type target | bpchar
Function |
Context |
System Cast? | Yes
Sql | -- Cast: "varchar::bpchar" CREATE CAST (varchar AS bpchar) WITHOUT FUNCTION AS IMPLICIT


char::text

Property | Value
Name | char::text
OID | 16507
Type source | char
Type target | text
Function | text
Context |
System Cast? | Yes
Sql | -- Cast: "char::text" CREATE CAST (char AS text) WITH FUNCTION text(char) AS IMPLICIT


char::bpchar

Property | Value
Name | char::bpchar
OID | 16508
Type source | char
Type target | bpchar
Function | bpchar
Context |
System Cast? | Yes
Sql | -- Cast: "char::bpchar" CREATE CAST (char AS bpchar) WITH FUNCTION bpchar(char) AS IMPLICIT


name::text

Property | Value
Name | name::text
OID | 16509
Type source | name
Type target | text
Function | text
Context |
System Cast? | Yes
Sql | -- Cast: "name::text" CREATE CAST (name AS text) WITH FUNCTION text(name) AS IMPLICIT


name::bpchar

Property | Value
Name | name::bpchar
OID | 16510
Type source | name
Type target | bpchar
Function | bpchar
Context |
System Cast? | Yes
Sql | -- Cast: "name::bpchar" CREATE CAST (name AS bpchar) WITH FUNCTION bpchar(name) AS IMPLICIT


name::varchar

Property | Value
Name | name::varchar
OID | 16511
Type source | name
Type target | varchar
Function | varchar
Context |
System Cast? | Yes
Sql | -- Cast: "name::varchar" CREATE CAST (name AS varchar) WITH FUNCTION varchar(name) AS IMPLICIT


text::char

Property | Value
Name | text::char
OID | 16512
Type source | text
Type target | char
Function | char
Context |
System Cast? | Yes
Sql | -- Cast: "text::char" CREATE CAST (text AS char) WITH FUNCTION char(text) AS ASSIGNMENT


text::name

Property | Value
Name | text::name
OID | 16513
Type source | text
Type target | name
Function | name
Context |
System Cast? | Yes
Sql | -- Cast: "text::name" CREATE CAST (text AS name) WITH FUNCTION name(text) AS IMPLICIT


bpchar::name

Property | Value
Name | bpchar::name
OID | 16514
Type source | bpchar
Type target | name
Function | name
Context |
System Cast? | Yes
Sql | -- Cast: "bpchar::name" CREATE CAST (bpchar AS name) WITH FUNCTION name(bpchar) AS IMPLICIT


varchar::name

Property | Value
Name | varchar::name
OID | 16515
Type source | varchar
Type target | name
Function | name
Context |
System Cast? | Yes
Sql | -- Cast: "varchar::name" CREATE CAST (varchar AS name) WITH FUNCTION name(varchar) AS IMPLICIT


abstime::date

Property | Value
Name | abstime::date
OID | 16516
Type source | abstime
Type target | date
Function | date
Context |
System Cast? | Yes
Sql | -- Cast: "abstime::date" CREATE CAST (abstime AS date) WITH FUNCTION date(abstime) AS ASSIGNMENT


abstime::time

Property | Value
Name | abstime::time
OID | 16517
Type source | abstime
Type target | time
Function | time
Context |
System Cast? | Yes
Sql | -- Cast: "abstime::time" CREATE CAST (abstime AS time) WITH FUNCTION time(abstime) AS ASSIGNMENT


abstime::timestamp

Property | Value
Name | abstime::timestamp
OID | 16518
Type source | abstime
Type target | timestamp
Function | timestamp
Context |
System Cast? | Yes
Sql | -- Cast: "abstime::timestamp" CREATE CAST (abstime AS timestamp) WITH FUNCTION timestamp(abstime) AS IMPLICIT


abstime::timestamptz

Property | Value
Name | abstime::timestamptz
OID | 16519
Type source | abstime
Type target | timestamptz
Function | timestamptz
Context |
System Cast? | Yes
Sql | -- Cast: "abstime::timestamptz" CREATE CAST (abstime AS timestamptz) WITH FUNCTION timestamptz(abstime) AS IMPLICIT


reltime::interval

Property | Value
Name | reltime::interval
OID | 16520
Type source | reltime
Type target | interval
Function | interval
Context |
System Cast? | Yes
Sql | -- Cast: "reltime::interval" CREATE CAST (reltime AS interval) WITH FUNCTION interval(reltime) AS IMPLICIT


date::timestamp

Property | Value
Name | date::timestamp
OID | 16521
Type source | date
Type target | timestamp
Function | timestamp
Context |
System Cast? | Yes
Sql | -- Cast: "date::timestamp" CREATE CAST (date AS timestamp) WITH FUNCTION timestamp(date) AS IMPLICIT


date::timestamptz

Property | Value
Name | date::timestamptz
OID | 16522
Type source | date
Type target | timestamptz
Function | timestamptz
Context |
System Cast? | Yes
Sql | -- Cast: "date::timestamptz" CREATE CAST (date AS timestamptz) WITH FUNCTION timestamptz(date) AS IMPLICIT


time::interval

Property | Value
Name | time::interval
OID | 16523
Type source | time
Type target | interval
Function | interval
Context |
System Cast? | Yes
Sql | -- Cast: "time::interval" CREATE CAST (time AS interval) WITH FUNCTION interval(time) AS IMPLICIT


time::timetz

Property | Value
Name | time::timetz
OID | 16524
Type source | time
Type target | timetz
Function | timetz
Context |
System Cast? | Yes
Sql | -- Cast: "time::timetz" CREATE CAST (time AS timetz) WITH FUNCTION timetz(time) AS IMPLICIT


timestamp::abstime

Property | Value
Name | timestamp::abstime
OID | 16525
Type source | timestamp
Type target | abstime
Function | abstime
Context |
System Cast? | Yes
Sql | -- Cast: "timestamp::abstime" CREATE CAST (timestamp AS abstime) WITH FUNCTION abstime(timestamp) AS ASSIGNMENT


timestamp::date

Property | Value
Name | timestamp::date
OID | 16526
Type source | timestamp
Type target | date
Function | date
Context |
System Cast? | Yes
Sql | -- Cast: "timestamp::date" CREATE CAST (timestamp AS date) WITH FUNCTION date(timestamp) AS ASSIGNMENT


timestamp::time

Property | Value
Name | timestamp::time
OID | 16527
Type source | timestamp
Type target | time
Function | time
Context |
System Cast? | Yes
Sql | -- Cast: "timestamp::time" CREATE CAST (timestamp AS time) WITH FUNCTION time(timestamp) AS ASSIGNMENT


timestamp::timestamptz

Property | Value
Name | timestamp::timestamptz
OID | 16528
Type source | timestamp
Type target | timestamptz
Function | timestamptz
Context |
System Cast? | Yes
Sql | -- Cast: "timestamp::timestamptz" CREATE CAST (timestamp AS timestamptz) WITH FUNCTION timestamptz(timestamp) AS IMPLICIT


timestamptz::abstime

Property | Value
Name | timestamptz::abstime
OID | 16529
Type source | timestamptz
Type target | abstime
Function | abstime
Context |
System Cast? | Yes
Sql | -- Cast: "timestamptz::abstime" CREATE CAST (timestamptz AS abstime) WITH FUNCTION abstime(timestamptz) AS ASSIGNMENT


timestamptz::date

Property | Value
Name | timestamptz::date
OID | 16530
Type source | timestamptz
Type target | date
Function | date
Context |
System Cast? | Yes
Sql | -- Cast: "timestamptz::date" CREATE CAST (timestamptz AS date) WITH FUNCTION date(timestamptz) AS ASSIGNMENT


timestamptz::time

Property | Value
Name | timestamptz::time
OID | 16531
Type source | timestamptz
Type target | time
Function | time
Context |
System Cast? | Yes
Sql | -- Cast: "timestamptz::time" CREATE CAST (timestamptz AS time) WITH FUNCTION time(timestamptz) AS ASSIGNMENT


timestamptz::timestamp

Property | Value
Name | timestamptz::timestamp
OID | 16532
Type source | timestamptz
Type target | timestamp
Function | timestamp
Context |
System Cast? | Yes
Sql | -- Cast: "timestamptz::timestamp" CREATE CAST (timestamptz AS timestamp) WITH FUNCTION timestamp(timestamptz) AS ASSIGNMENT


timestamptz::timetz

Property | Value
Name | timestamptz::timetz
OID | 16533
Type source | timestamptz
Type target | timetz
Function | timetz
Context |
System Cast? | Yes
Sql | -- Cast: "timestamptz::timetz" CREATE CAST (timestamptz AS timetz) WITH FUNCTION timetz(timestamptz) AS ASSIGNMENT


interval::reltime

Property | Value
Name | interval::reltime
OID | 16534
Type source | interval
Type target | reltime
Function | reltime
Context |
System Cast? | Yes
Sql | -- Cast: "interval::reltime" CREATE CAST (interval AS reltime) WITH FUNCTION reltime(interval) AS ASSIGNMENT


interval::time

Property | Value
Name | interval::time
OID | 16535
Type source | interval
Type target | time
Function | time
Context |
System Cast? | Yes
Sql | -- Cast: "interval::time" CREATE CAST (interval AS time) WITH FUNCTION time(interval) AS ASSIGNMENT


timetz::time

Property | Value
Name | timetz::time
OID | 16536
Type source | timetz
Type target | time
Function | time
Context |
System Cast? | Yes
Sql | -- Cast: "timetz::time" CREATE CAST (timetz AS time) WITH FUNCTION time(timetz) AS ASSIGNMENT


int4::abstime

Property | Value
Name | int4::abstime
OID | 16537
Type source | int4
Type target | abstime
Function |
Context |
System Cast? | Yes
Sql | -- Cast: "int4::abstime" CREATE CAST (int4 AS abstime) WITHOUT FUNCTION


abstime::int4

Property | Value
Name | abstime::int4
OID | 16538
Type source | abstime
Type target | int4
Function |
Context |
System Cast? | Yes
Sql | -- Cast: "abstime::int4" CREATE CAST (abstime AS int4) WITHOUT FUNCTION


int4::reltime

Property | Value
Name | int4::reltime
OID | 16539
Type source | int4
Type target | reltime
Function |
Context |
System Cast? | Yes
Sql | -- Cast: "int4::reltime" CREATE CAST (int4 AS reltime) WITHOUT FUNCTION


reltime::int4

Property | Value
Name | reltime::int4
OID | 16540
Type source | reltime
Type target | int4
Function |
Context |
System Cast? | Yes
Sql | -- Cast: "reltime::int4" CREATE CAST (reltime AS int4) WITHOUT FUNCTION


lseg::point

Property | Value
Name | lseg::point
OID | 16541
Type source | lseg
Type target | point
Function | point
Context |
System Cast? | Yes
Sql | -- Cast: "lseg::point" CREATE CAST (lseg AS point) WITH FUNCTION point(lseg)


path::point

Property | Value
Name | path::point
OID | 16542
Type source | path
Type target | point
Function | point
Context |
System Cast? | Yes
Sql | -- Cast: "path::point" CREATE CAST (path AS point) WITH FUNCTION point(path)


path::polygon

Property | Value
Name | path::polygon
OID | 16543
Type source | path
Type target | polygon
Function | polygon
Context |
System Cast? | Yes
Sql | -- Cast: "path::polygon" CREATE CAST (path AS polygon) WITH FUNCTION polygon(path) AS ASSIGNMENT


box::point

Property | Value
Name | box::point
OID | 16544
Type source | box
Type target | point
Function | point
Context |
System Cast? | Yes
Sql | -- Cast: "box::point" CREATE CAST (box AS point) WITH FUNCTION point(box)


box::lseg

Property | Value
Name | box::lseg
OID | 16545
Type source | box
Type target | lseg
Function | lseg
Context |
System Cast? | Yes
Sql | -- Cast: "box::lseg" CREATE CAST (box AS lseg) WITH FUNCTION lseg(box)


box::polygon

Property | Value
Name | box::polygon
OID | 16546
Type source | box
Type target | polygon
Function | polygon
Context |
System Cast? | Yes
Sql | -- Cast: "box::polygon" CREATE CAST (box AS polygon) WITH FUNCTION polygon(box) AS ASSIGNMENT


box::circle

Property | Value
Name | box::circle
OID | 16547
Type source | box
Type target | circle
Function | circle
Context |
System Cast? | Yes
Sql | -- Cast: "box::circle" CREATE CAST (box AS circle) WITH FUNCTION circle(box)


polygon::point

Property | Value
Name | polygon::point
OID | 16548
Type source | polygon
Type target | point
Function | point
Context |
System Cast? | Yes
Sql | -- Cast: "polygon::point" CREATE CAST (polygon AS point) WITH FUNCTION point(polygon)


polygon::path

Property | Value
Name | polygon::path
OID | 16549
Type source | polygon
Type target | path
Function | path
Context |
System Cast? | Yes
Sql | -- Cast: "polygon::path" CREATE CAST (polygon AS path) WITH FUNCTION path(polygon) AS ASSIGNMENT


polygon::box

Property | Value
Name | polygon::box
OID | 16550
Type source | polygon
Type target | box
Function | box
Context |
System Cast? | Yes
Sql | -- Cast: "polygon::box" CREATE CAST (polygon AS box) WITH FUNCTION box(polygon)


polygon::circle

Property | Value
Name | polygon::circle
OID | 16551
Type source | polygon
Type target | circle
Function | circle
Context |
System Cast? | Yes
Sql | -- Cast: "polygon::circle" CREATE CAST (polygon AS circle) WITH FUNCTION circle(polygon)


circle::point

Property | Value
Name | circle::point
OID | 16552
Type source | circle
Type target | point
Function | point
Context |
System Cast? | Yes
Sql | -- Cast: "circle::point" CREATE CAST (circle AS point) WITH FUNCTION point(circle)


circle::box

Property | Value
Name | circle::box
OID | 16553
Type source | circle
Type target | box
Function | box
Context |
System Cast? | Yes
Sql | -- Cast: "circle::box" CREATE CAST (circle AS box) WITH FUNCTION box(circle)


circle::polygon

Property | Value
Name | circle::polygon
OID | 16554
Type source | circle
Type target | polygon
Function | polygon
Context |
System Cast? | Yes
Sql | -- Cast: "circle::polygon" CREATE CAST (circle AS polygon) WITH FUNCTION polygon(circle)


cidr::inet

Property | Value
Name | cidr::inet
OID | 16555
Type source | cidr
Type target | inet
Function |
Context |
System Cast? | Yes
Sql | -- Cast: "cidr::inet" CREATE CAST (cidr AS inet) WITHOUT FUNCTION AS IMPLICIT


inet::cidr

Property | Value
Name | inet::cidr
OID | 16556
Type source | inet
Type target | cidr
Function |
Context |
System Cast? | Yes
Sql | -- Cast: "inet::cidr" CREATE CAST (inet AS cidr) WITHOUT FUNCTION AS IMPLICIT


bit::varbit

Property | Value
Name | bit::varbit
OID | 16557
Type source | bit
Type target | varbit
Function |
Context |
System Cast? | Yes
Sql | -- Cast: "bit::varbit" CREATE CAST (bit AS varbit) WITHOUT FUNCTION AS IMPLICIT


varbit::bit

Property | Value
Name | varbit::bit
OID | 16558
Type source | varbit
Type target | bit
Function |
Context |
System Cast? | Yes
Sql | -- Cast: "varbit::bit" CREATE CAST (varbit AS bit) WITHOUT FUNCTION AS IMPLICIT


int8::bit

Property | Value
Name | int8::bit
OID | 16559
Type source | int8
Type target | bit
Function | bit
Context |
System Cast? | Yes
Sql | -- Cast: "int8::bit" CREATE CAST (int8 AS bit) WITH FUNCTION bit(int8)


int4::bit

Property | Value
Name | int4::bit
OID | 16560
Type source | int4
Type target | bit
Function | bit
Context |
System Cast? | Yes
Sql | -- Cast: "int4::bit" CREATE CAST (int4 AS bit) WITH FUNCTION bit(int4)


bit::int8

Property | Value
Name | bit::int8
OID | 16561
Type source | bit
Type target | int8
Function | int8
Context |
System Cast? | Yes
Sql | -- Cast: "bit::int8" CREATE CAST (bit AS int8) WITH FUNCTION int8(bit)


bit::int4

Property | Value
Name | bit::int4
OID | 16562
Type source | bit
Type target | int4
Function | int4
Context |
System Cast? | Yes
Sql | -- Cast: "bit::int4" CREATE CAST (bit AS int4) WITH FUNCTION int4(bit)


int8::text

Property | Value
Name | int8::text
OID | 16563
Type source | int8
Type target | text
Function | text
Context |
System Cast? | Yes
Sql | -- Cast: "int8::text" CREATE CAST (int8 AS text) WITH FUNCTION text(int8) AS IMPLICIT


text::int8

Property | Value
Name | text::int8
OID | 16564
Type source | text
Type target | int8
Function | int8
Context |
System Cast? | Yes
Sql | -- Cast: "text::int8" CREATE CAST (text AS int8) WITH FUNCTION int8(text)


int2::text

Property | Value
Name | int2::text
OID | 16565
Type source | int2
Type target | text
Function | text
Context |
System Cast? | Yes
Sql | -- Cast: "int2::text" CREATE CAST (int2 AS text) WITH FUNCTION text(int2) AS IMPLICIT


text::int2

Property | Value
Name | text::int2
OID | 16566
Type source | text
Type target | int2
Function | int2
Context |
System Cast? | Yes
Sql | -- Cast: "text::int2" CREATE CAST (text AS int2) WITH FUNCTION int2(text)


int4::text

Property | Value
Name | int4::text
OID | 16567
Type source | int4
Type target | text
Function | text
Context |
System Cast? | Yes
Sql | -- Cast: "int4::text" CREATE CAST (int4 AS text) WITH FUNCTION text(int4) AS IMPLICIT


text::int4

Property | Value
Name | text::int4
OID | 16568
Type source | text
Type target | int4
Function | int4
Context |
System Cast? | Yes
Sql | -- Cast: "text::int4" CREATE CAST (text AS int4) WITH FUNCTION int4(text)


oid::text

Property | Value
Name | oid::text
OID | 16569
Type source | oid
Type target | text
Function | text
Context |
System Cast? | Yes
Sql | -- Cast: "oid::text" CREATE CAST (oid AS text) WITH FUNCTION text(oid) AS IMPLICIT


text::oid

Property | Value
Name | text::oid
OID | 16570
Type source | text
Type target | oid
Function | oid
Context |
System Cast? | Yes
Sql | -- Cast: "text::oid" CREATE CAST (text AS oid) WITH FUNCTION oid(text)


text::cidr

Property | Value
Name | text::cidr
OID | 16571
Type source | text
Type target | cidr
Function | cidr
Context |
System Cast? | Yes
Sql | -- Cast: "text::cidr" CREATE CAST (text AS cidr) WITH FUNCTION cidr(text)


float4::text

Property | Value
Name | float4::text
OID | 16572
Type source | float4
Type target | text
Function | text
Context |
System Cast? | Yes
Sql | -- Cast: "float4::text" CREATE CAST (float4 AS text) WITH FUNCTION text(float4) AS IMPLICIT


text::float4

Property | Value
Name | text::float4
OID | 16573
Type source | text
Type target | float4
Function | float4
Context |
System Cast? | Yes
Sql | -- Cast: "text::float4" CREATE CAST (text AS float4) WITH FUNCTION float4(text)


float8::text

Property | Value
Name | float8::text
OID | 16574
Type source | float8
Type target | text
Function | text
Context |
System Cast? | Yes
Sql | -- Cast: "float8::text" CREATE CAST (float8 AS text) WITH FUNCTION text(float8) AS IMPLICIT


text::float8

Property | Value
Name | text::float8
OID | 16575
Type source | text
Type target | float8
Function | float8
Context |
System Cast? | Yes
Sql | -- Cast: "text::float8" CREATE CAST (text AS float8) WITH FUNCTION float8(text)


macaddr::text

Property | Value
Name | macaddr::text
OID | 16576
Type source | macaddr
Type target | text
Function | text
Context |
System Cast? | Yes
Sql | -- Cast: "macaddr::text" CREATE CAST (macaddr AS text) WITH FUNCTION text(macaddr)


text::macaddr

Property | Value
Name | text::macaddr
OID | 16577
Type source | text
Type target | macaddr
Function | macaddr
Context |
System Cast? | Yes
Sql | -- Cast: "text::macaddr" CREATE CAST (text AS macaddr) WITH FUNCTION macaddr(text)


inet::text

Property | Value
Name | inet::text
OID | 16578
Type source | inet
Type target | text
Function | text
Context |
System Cast? | Yes
Sql | -- Cast: "inet::text" CREATE CAST (inet AS text) WITH FUNCTION text(inet)


text::inet

Property | Value
Name | text::inet
OID | 16579
Type source | text
Type target | inet
Function | inet
Context |
System Cast? | Yes
Sql | -- Cast: "text::inet" CREATE CAST (text AS inet) WITH FUNCTION inet(text)


date::text

Property | Value
Name | date::text
OID | 16580
Type source | date
Type target | text
Function | text
Context |
System Cast? | Yes
Sql | -- Cast: "date::text" CREATE CAST (date AS text) WITH FUNCTION text(date) AS IMPLICIT


text::date

Property | Value
Name | text::date
OID | 16581
Type source | text
Type target | date
Function | date
Context |
System Cast? | Yes
Sql | -- Cast: "text::date" CREATE CAST (text AS date) WITH FUNCTION date(text)


time::text

Property | Value
Name | time::text
OID | 16582
Type source | time
Type target | text
Function | text
Context |
System Cast? | Yes
Sql | -- Cast: "time::text" CREATE CAST (time AS text) WITH FUNCTION text(time) AS IMPLICIT


text::time

Property | Value
Name | text::time
OID | 16583
Type source | text
Type target | time
Function | time
Context |
System Cast? | Yes
Sql | -- Cast: "text::time" CREATE CAST (text AS time) WITH FUNCTION time(text)


timestamp::text

Property | Value
Name | timestamp::text
OID | 16584
Type source | timestamp
Type target | text
Function | text
Context |
System Cast? | Yes
Sql | -- Cast: "timestamp::text" CREATE CAST (timestamp AS text) WITH FUNCTION text(timestamp) AS IMPLICIT


text::timestamp

Property | Value
Name | text::timestamp
OID | 16585
Type source | text
Type target | timestamp
Function | timestamp
Context |
System Cast? | Yes
Sql | -- Cast: "text::timestamp" CREATE CAST (text AS timestamp) WITH FUNCTION timestamp(text)


timestamptz::text

Property | Value
Name | timestamptz::text
OID | 16586
Type source | timestamptz
Type target | text
Function | text
Context |
System Cast? | Yes
Sql | -- Cast: "timestamptz::text" CREATE CAST (timestamptz AS text) WITH FUNCTION text(timestamptz) AS IMPLICIT


text::timestamptz

Property | Value
Name | text::timestamptz
OID | 16587
Type source | text
Type target | timestamptz
Function | timestamptz
Context |
System Cast? | Yes
Sql | -- Cast: "text::timestamptz" CREATE CAST (text AS timestamptz) WITH FUNCTION timestamptz(text)


interval::text

Property | Value
Name | interval::text
OID | 16588
Type source | interval
Type target | text
Function | text
Context |
System Cast? | Yes
Sql | -- Cast: "interval::text" CREATE CAST (interval AS text) WITH FUNCTION text(interval) AS IMPLICIT


text::interval

Property | Value
Name | text::interval
OID | 16589
Type source | text
Type target | interval
Function | interval
Context |
System Cast? | Yes
Sql | -- Cast: "text::interval" CREATE CAST (text AS interval) WITH FUNCTION interval(text)


timetz::text

Property | Value
Name | timetz::text
OID | 16590
Type source | timetz
Type target | text
Function | text
Context |
System Cast? | Yes
Sql | -- Cast: "timetz::text" CREATE CAST (timetz AS text) WITH FUNCTION text(timetz) AS IMPLICIT


text::timetz

Property | Value
Name | text::timetz
OID | 16591
Type source | text
Type target | timetz
Function | timetz
Context |
System Cast? | Yes
Sql | -- Cast: "text::timetz" CREATE CAST (text AS timetz) WITH FUNCTION timetz(text)


numeric::text

Property | Value
Name | numeric::text
OID | 16592
Type source | numeric
Type target | text
Function | text
Context |
System Cast? | Yes
Sql | -- Cast: "numeric::text" CREATE CAST (numeric AS text) WITH FUNCTION text(numeric) AS IMPLICIT


text::numeric

Property | Value
Name | text::numeric
OID | 16593
Type source | text
Type target | numeric
Function | numeric
Context |
System Cast? | Yes
Sql | -- Cast: "text::numeric" CREATE CAST (text AS numeric) WITH FUNCTION numeric(text)