Re: Teach pg_receivewal to use lz4 compression - Mailing list pgsql-hackers
From | gkokolatos@pm.me |
---|---|
Subject | Re: Teach pg_receivewal to use lz4 compression |
Date | |
Msg-id | S2rA_l89FgB0CtpkaBoPe0DTjvkvo46zUzlZxilMGzlDCICb5rwmrKXg1bzpp5ZO75GF-b7ayvG9dihbzRwOKVawLLreJbWWGfY6OdhSpho=@pm.me Whole thread Raw |
In response to | Re: Teach pg_receivewal to use lz4 compression (Magnus Hagander <magnus@hagander.net>) |
Responses |
Re: Teach pg_receivewal to use lz4 compression
|
List | pgsql-hackers |
‐‐‐‐‐‐‐ Original Message ‐‐‐‐‐‐‐ On Thursday, July 1st, 2021 at 15:58, Magnus Hagander <magnus@hagander.net> wrote: > On Thu, Jul 1, 2021 at 3:39 PM gkokolatos@pm.me wrote: > > > ‐‐‐‐‐‐‐ Original Message ‐‐‐‐‐‐‐ > > > > On Thursday, July 1st, 2021 at 12:28, Magnus Hagander magnus@hagander.net wrote: > > > > > On Wed, Jun 30, 2021 at 8:34 AM Dilip Kumar dilipbalaut@gmail.com wrote: > > > > > > > On Tue, Jun 29, 2021 at 8:15 PM gkokolatos@pm.me wrote: > > > > > > > > > Hi, > > > > > > > > > > The program pg_receivewal can use gzip compression to store the received WAL. > > > > > > > > > > This patch teaches it to be able to use lz4 compression if the binary is build > > > > > > > > > > using the -llz4 flag. > > > > > > > > +1 for the idea > > > > > > > > Some comments/suggestions on the patch > > > > > > > > @@ -90,7 +91,8 @@ usage(void) > > > > > > > > printf((" --synchronous flush write-ahead log immediately > > > > > > > > after writing\n")); > > > > > > > > printf((" -v, --verbose output verbose messages\n")); > > > > > > > > printf(_(" -V, --version output version information, then exit\n")); > > > > > > > > - printf(_(" -Z, --compress=0-9 compress logs with given > > > > > > > > compression level\n")); > > > > > > > > - printf(_(" -I, --compress-program use this program for compression\n")); > > > > > > > > > > > > Wouldn't it be better to call it compression method instead of > > > > > > > > compression program? > > > > > > I came here to say exactly that, just had to think up what I thought > > > > > > was the better name first. Either method or algorithm, but method > > > > > > seems like the much simpler choice and therefore better in this case. > > > > > > Should is also then not be --compression-method, rather than --compress-method? > > > > Not a problem. To be very transparent, I first looked what was already out there. > > > > For example `tar` is using > > > > -I, --use-compress-program=PROG > > > > yet the 'use-' bit would push the alignment of the --help output, so I removed it. > > I think the difference there is that tar actually calls an external > > program to do the work... And we are using the built-in library, > > right? You are very correct :) I am not objecting the change at all. Just let you know how I chose that. You know, naming is dead easy and all... On a more serious note, what about the `-I` short flag? Should we keep it or is there a better one to be used? Micheal suggested on the same thread to move my entry in the help output so that the output remains ordered. I would like the options for the compression method and the already existing compression level to next to each other if possible. Then it should be either 'X' or 'Y'. Thoughts? > > ------------------------------------------------------------------------------------------------------------------------------------------------ > > Magnus Hagander > > Me: https://www.hagander.net/ > > Work: https://www.redpill-linpro.com/
pgsql-hackers by date: