Thread: pgsql: Update portal-related memory context names and API

pgsql: Update portal-related memory context names and API

From
Peter Eisentraut
Date:
Update portal-related memory context names and API

Rename PortalMemory to TopPortalContext, to avoid confusion with
PortalContext and align naming with similar top-level memory contexts.

Rename PortalData's "heap" field to portalContext.  The "heap" naming
seems quite antiquated and confusing.  Also get rid of the
PortalGetHeapMemory() macro and access the field directly, which we do
for other portal fields, so this abstraction doesn't buy anything.

Reviewed-by: Andrew Dunstan <andrew.dunstan@2ndquadrant.com>
Reviewed-by: Alvaro Herrera <alvherre@alvh.no-ip.org>

Branch
------
master

Details
-------
https://git.postgresql.org/pg/commitdiff/0f7c49e85518dd846ccd0a044d49a922b9132983

Modified Files
--------------
src/backend/commands/portalcmds.c  | 10 +++++-----
src/backend/commands/prepare.c     |  2 +-
src/backend/executor/spi.c         |  6 +++---
src/backend/tcop/postgres.c        |  2 +-
src/backend/tcop/pquery.c          | 16 ++++++++--------
src/backend/utils/mmgr/portalmem.c | 32 ++++++++++++++++----------------
src/include/utils/portal.h         |  3 +--
7 files changed, 35 insertions(+), 36 deletions(-)